# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[a-z])(?=[A-Z])/ /gm;t' <<< "\"name\": \"CapitalCaseWords\"
\"name\": \"AnotherStringSentence\"
\"ThisStringShouldntBeReplaced\""