re = /(?<=[a-z])(?=[A-Z])/m
str = '"name": "CapitalCaseWords"
"name": "AnotherStringSentence"
"ThisStringShouldntBeReplaced"'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result