#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?UD)\[(?P<Manufacture>3G|EL)\*(?P<DeviceId>[0-9]{10})\*(?P<Length>[A-Z0-9]{4})\*(?P<Command>.+)[\]|,]{1}(.*)"
Local $sString = "[3G*2110620000*000A*UD]" & @CRLF & _
"[3G*2110620000*000A*LK,0,0,100][3G*2110620000*000A*LK,0,0,100]" & @CRLF & _
"[3G*2110620000*000A*LK,0,0,100][3G*2110620000*000A*LK][3G*2110620000*000A*LK,0,0,100]" & @CRLF & _
"[3G*2110620000*000A*LK,100]" & @CRLF & _
"[EL*2110620006*000A*LK,0,0],100]]]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")