re = /\[(?P<Manufacture>3G|EL)\*(?P<DeviceId>[0-9]{10})\*(?P<Length>[A-Z0-9]{4})\*(?P<Command>.+)[\]|,]{1}(.*)/
str = '[3G*2110620000*000A*UD]
[3G*2110620000*000A*LK,0,0,100][3G*2110620000*000A*LK,0,0,100]
[3G*2110620000*000A*LK,0,0,100][3G*2110620000*000A*LK][3G*2110620000*000A*LK,0,0,100]
[3G*2110620000*000A*LK,100]
[EL*2110620006*000A*LK,0,0],100]]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end