const regex = new RegExp('\\[(?P<Manufacture>3G|EL)\\*(?P<DeviceId>[0-9]{10})\\*(?P<Length>[A-Z0-9]{4})\\*(?P<Command>.+)[\\]|,]{1}(.*)', 'g')
const str = `[3G*2110620000*000A*UD]
[3G*2110620000*000A*LK,0,0,100][3G*2110620000*000A*LK,0,0,100]
[3G*2110620000*000A*LK,0,0,100][3G*2110620000*000A*LK][3G*2110620000*000A*LK,0,0,100]
[3G*2110620000*000A*LK,100]
[EL*2110620006*000A*LK,0,0],100]]]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}