#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?msi)(pwd|password).*?\{\{(.*?)\}\}|(usr|username).*?\{\{(.*?)\}\}"
Local $sString = "File 0:" & @CRLF & _
" "body": {" & @CRLF & _
" "mode": "raw"," & @CRLF & _
" "raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"password\": \"{{password}}\",\n \"userName\": \"{{userName}}\"\n}"" & @CRLF & _
" }," & @CRLF & _
" "url": {" & @CRLF & _
"" & @CRLF & _
"File 1:" & @CRLF & _
" "body": {" & @CRLF & _
" "mode": "raw"," & @CRLF & _
" "raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"pwd\": \"{{d]5!bT8**<\fcaY?}}\",\n \"usr\": \"{{example.user1}}\"\n}"" & @CRLF & _
" }," & @CRLF & _
" "url": {" & @CRLF & _
"" & @CRLF & _
"File 2:" & @CRLF & _
""body": {" & @CRLF & _
" "mode": "raw"," & @CRLF & _
" "raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"password\": \"{{h+Rq~%d7kQ_\ew%]}}\",\n \"usr\": \"{{example.user2}}\"\n}"" & @CRLF & _
"}," & @CRLF & _
""url": {" & @CRLF & _
"" & @CRLF & _
"File 3:" & @CRLF & _
""body": {" & @CRLF & _
" "mode": "raw"," & @CRLF & _
" "raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"pwd\": \"{{Y4)8-SnkVYZ>=wKn}}\",\n \"username\": \"{{example.user3}}\"\n}"" & @CRLF & _
"}," & @CRLF & _
""url": {" & @CRLF & _
"" & @CRLF & _
"File 4:" & @CRLF & _
""body": {" & @CRLF & _
" "mode": "raw"," & @CRLF & _
" "raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"pwd\": \"{{,;F3QV(3~JB)grM{}}\",\n "\n}"" & @CRLF & _
"}," & @CRLF & _
""url": {"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")