using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?msi)(pwd|password).*?\{\{(.*?)\}\}|(usr|username).*?\{\{(.*?)\}\}";
string input = @"File 0:
""body"": {
""mode"": ""raw"",
""raw"": ""{\n \""partnerCode\"": \""{{partner}}\"",\n \""password\"": \""{{password}}\"",\n \""userName\"": \""{{userName}}\""\n}""
},
""url"": {
File 1:
""body"": {
""mode"": ""raw"",
""raw"": ""{\n \""partnerCode\"": \""{{partner}}\"",\n \""pwd\"": \""{{d]5!bT8**<\fcaY?}}\"",\n \""usr\"": \""{{example.user1}}\""\n}""
},
""url"": {
File 2:
""body"": {
""mode"": ""raw"",
""raw"": ""{\n \""partnerCode\"": \""{{partner}}\"",\n \""password\"": \""{{h+Rq~%d7kQ_\ew%]}}\"",\n \""usr\"": \""{{example.user2}}\""\n}""
},
""url"": {
File 3:
""body"": {
""mode"": ""raw"",
""raw"": ""{\n \""partnerCode\"": \""{{partner}}\"",\n \""pwd\"": \""{{Y4)8-SnkVYZ>=wKn}}\"",\n \""username\"": \""{{example.user3}}\""\n}""
},
""url"": {
File 4:
""body"": {
""mode"": ""raw"",
""raw"": ""{\n \""partnerCode\"": \""{{partner}}\"",\n \""pwd\"": \""{{,;F3QV(3~JB)grM{}}\"",\n ""\n}""
},
""url"": {";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}