import Foundation
let pattern = #"(?msi)(pwd|password).*?\{\{(.*?)\}\}|(usr|username).*?\{\{(.*?)\}\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
File 0:
"body": {
"mode": "raw",
"raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"password\": \"{{password}}\",\n \"userName\": \"{{userName}}\"\n}"
},
"url": {
File 1:
"body": {
"mode": "raw",
"raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"pwd\": \"{{d]5!bT8**<\fcaY?}}\",\n \"usr\": \"{{example.user1}}\"\n}"
},
"url": {
File 2:
"body": {
"mode": "raw",
"raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"password\": \"{{h+Rq~%d7kQ_\ew%]}}\",\n \"usr\": \"{{example.user2}}\"\n}"
},
"url": {
File 3:
"body": {
"mode": "raw",
"raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"pwd\": \"{{Y4)8-SnkVYZ>=wKn}}\",\n \"username\": \"{{example.user3}}\"\n}"
},
"url": {
File 4:
"body": {
"mode": "raw",
"raw": "{\n \"partnerCode\": \"{{partner}}\",\n \"pwd\": \"{{,;F3QV(3~JB)grM{}}\",\n "\n}"
},
"url": {
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)