using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[a-zA-Z0-9]+\d*[-_])*[a-zA-Z]+\d*(?:_64)?)";
string input = @"kernel-debug-modules-extra-4.18.0-80.2.el8.x86_64.rpm
kernel-debug2-modules-extra-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-modules2-extra-4.18.0-80.2.el8.x86_64.rpm
kernel-debug3-modules-extra2-4.18.0-80.2.el8.x86_64.rpm
KERNEL-DEBUG-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-core-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-devel-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-modules-4.18.0-80.2.el8.x86_64.rpm
2python3-perf-4.18.0-80.2.el8.x86_64.rpm
python3-perf2-4.18.0-80.2.el8.x86_64.rpm
kernel-debuginfo-common-x86_64-4.18.0-80.2.el8.x86_64.rpm
Kernel_debUginfo_common-x86_64-4.18.0-80.2.el8.x86_64.rpm
python3-4.18.0-80.2.el8.x86_64.rpm
python-4.18.0-80.2.el8.x86_64.rpm
----
desired output (exlude words which starts with hypen and digit (-4.xxx) and exclude -x86_64):
kernel-debug-modules-extra
kernel-debug2-modules-extra
kernel-debug
python3
---
error:
python3-4.18.0-80.2.el8.x86_64.rpm - not matching single word
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}