# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:[a-zA-Z0-9]+\d*[-_])*[a-zA-Z]+\d*(?:_64)?)"
test_str = ("kernel-debug-modules-extra-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debug2-modules-extra-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debug-modules2-extra-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debug3-modules-extra2-4.18.0-80.2.el8.x86_64.rpm\n"
"KERNEL-DEBUG-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debug-core-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debug-devel-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debug-modules-4.18.0-80.2.el8.x86_64.rpm\n"
"2python3-perf-4.18.0-80.2.el8.x86_64.rpm\n"
"python3-perf2-4.18.0-80.2.el8.x86_64.rpm\n"
"kernel-debuginfo-common-x86_64-4.18.0-80.2.el8.x86_64.rpm\n"
"Kernel_debUginfo_common-x86_64-4.18.0-80.2.el8.x86_64.rpm\n"
"python3-4.18.0-80.2.el8.x86_64.rpm\n"
"python-4.18.0-80.2.el8.x86_64.rpm\n\n"
"----\n"
"desired output (exlude words which starts with hypen and digit (-4.xxx) and exclude -x86_64):\n"
"kernel-debug-modules-extra\n"
"kernel-debug2-modules-extra\n"
"kernel-debug\n"
"python3\n"
"---\n"
"error:\n"
"python3-4.18.0-80.2.el8.x86_64.rpm - not matching single word\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.