package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)--([^;]*);`)
var str = `some text --text_to_be_replaced; and another text -- text
to
be
replaced; and some text...;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}