re = /--([^;]*);/m
str = 'some text --text_to_be_replaced; and another text -- text
to
be
replaced; and some text...;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end