$re = '/--([^;]*);/ms';
$str = 'some text --text_to_be_replaced; and another text -- text
to
be
replaced; and some text...;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);