using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""the[^@]*?fox[^@]*?lazy[^@]*?""$";
string input = @"""the quick brown fox
jumped over the lazy dog""
this string should not be selected
this string should not be selected
""the quick brown fox
jumped over the lazy dog""
""the quick brown fox jumped over the lazy dog""
this string should not be selected
the quick brown fox
jumped over the lazy dog
the quick brown fox jumped over the lazy dog
this string should not be selected";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}