// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)^"the[^@]*?fox[^@]*?lazy[^@]*?"$"#).unwrap();
let string = "\"the quick brown fox
jumped over the lazy dog\"
this string should not be selected
this string should not be selected
\"the quick brown fox
jumped over the lazy dog\"
\"the quick brown fox jumped over the lazy dog\"
this string should not be selected
the quick brown fox
jumped over the lazy dog
the quick brown fox jumped over the lazy dog
this string should not be selected";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}