import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"the[^@]*?fox[^@]*?lazy[^@]*?\"$";
final String string = "\"the quick brown fox \n"
+ "jumped over the lazy dog\"\n"
+ "this string should not be selected\n"
+ "this string should not be selected\n"
+ "\"the quick brown fox \n"
+ "jumped over the lazy dog\"\n"
+ "\"the quick brown fox jumped over the lazy dog\"\n"
+ "this string should not be selected\n"
+ "the quick brown fox \n"
+ "jumped over the lazy dog\n"
+ "the quick brown fox jumped over the lazy dog\n"
+ "this string should not be selected";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}