#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:(?:(?:31(?:(?:([-.\/])(?:0?[13578]|1[02])\2)|(?:([-.\/ ])(?:Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\3)))|(?:(?:29|30)(?:(?:([-.\/])(?:0?[13-9]|1[0-2])\4)|(?:([-.\/ ])(?:Jan|JAN|Mar|MAR|Apr|APR|May|MAY|Jun|JUN|Jul|JUL|Aug|AUG|Sep|SEP|Oct|OCT|Nov|NOV|Dec|DEC)\5))))(?:(?:1[6-9]|[2-9]\d)?\d{2}))$|^(?:29(?:(?:([-.\/])(?:0?2)\6)|(?:([-.\/ ])(?:Feb|FEB)\7))(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))$|^(?:(?:0?[1-9]|1\d|2[0-8])(?:(?:([-.\/])(?:(?:0?[1-9]|(?:1[0-2])))\8)|(?:([-.\/ ])(?:Jan|JAN|Feb|FEB|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\9))(?:(?:1[6-9]|[2-9]\d)?\d{2}))$)"
Local $sString = "01/01/2000" & @CRLF & _
"31/01/2000" & @CRLF & _
"32/01/2000" & @CRLF & _
"" & @CRLF & _
"01/1/2000" & @CRLF & _
"01/1/01" & @CRLF & _
"" & @CRLF & _
"29/02/2000" & @CRLF & _
"28/02/2001" & @CRLF & _
"29/02/2001" & @CRLF & _
"" & @CRLF & _
"30/04/2000" & @CRLF & _
"31/04/2000" & @CRLF & _
"31/07/2000" & @CRLF & _
"31/08/2000" & @CRLF & _
"31/09/2000" & @CRLF & _
"" & @CRLF & _
"01/12/2000" & @CRLF & _
"01/15/2000" & @CRLF & _
"" & @CRLF & _
"29-02-2020" & @CRLF & _
"29-02-2024" & @CRLF & _
"29-02-2000" & @CRLF & _
"29-02-2100" & @CRLF & _
"29-02-2400" & @CRLF & _
"" & @CRLF & _
"29-0,-11" & @CRLF & _
"" & @CRLF & _
"01/Mar/2020" & @CRLF & _
"29/Mar/2020" & @CRLF & _
"31 Jul 2020" & @CRLF & _
"30 Apr 2020" & @CRLF & _
"29 Feb 2020" & @CRLF & _
"29 May 2100" & @CRLF & _
"8 Aug 2020" & @CRLF & _
"26 OCT 2024" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")