const regex = /(^(?:(?:(?:31(?:(?:([-.\/])(?:0?[13578]|1[02])\2)|(?:([-.\/ ])(?:Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\3)))|(?:(?:29|30)(?:(?:([-.\/])(?:0?[13-9]|1[0-2])\4)|(?:([-.\/ ])(?:Jan|JAN|Mar|MAR|Apr|APR|May|MAY|Jun|JUN|Jul|JUL|Aug|AUG|Sep|SEP|Oct|OCT|Nov|NOV|Dec|DEC)\5))))(?:(?:1[6-9]|[2-9]\d)?\d{2}))$|^(?:29(?:(?:([-.\/])(?:0?2)\6)|(?:([-.\/ ])(?:Feb|FEB)\7))(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))$|^(?:(?:0?[1-9]|1\d|2[0-8])(?:(?:([-.\/])(?:(?:0?[1-9]|(?:1[0-2])))\8)|(?:([-.\/ ])(?:Jan|JAN|Feb|FEB|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\9))(?:(?:1[6-9]|[2-9]\d)?\d{2}))$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?:(?:(?:31(?:(?:([-.\\\/])(?:0?[13578]|1[02])\\2)|(?:([-.\\\/ ])(?:Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\\3)))|(?:(?:29|30)(?:(?:([-.\\\/])(?:0?[13-9]|1[0-2])\\4)|(?:([-.\\\/ ])(?:Jan|JAN|Mar|MAR|Apr|APR|May|MAY|Jun|JUN|Jul|JUL|Aug|AUG|Sep|SEP|Oct|OCT|Nov|NOV|Dec|DEC)\\5))))(?:(?:1[6-9]|[2-9]\\d)?\\d{2}))$|^(?:29(?:(?:([-.\\\/])(?:0?2)\\6)|(?:([-.\\\/ ])(?:Feb|FEB)\\7))(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))$|^(?:(?:0?[1-9]|1\\d|2[0-8])(?:(?:([-.\\\/])(?:(?:0?[1-9]|(?:1[0-2])))\\8)|(?:([-.\\\/ ])(?:Jan|JAN|Feb|FEB|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)\\9))(?:(?:1[6-9]|[2-9]\\d)?\\d{2}))$)', 'gm')
const str = `01/01/2000
31/01/2000
32/01/2000
01/1/2000
01/1/01
29/02/2000
28/02/2001
29/02/2001
30/04/2000
31/04/2000
31/07/2000
31/08/2000
31/09/2000
01/12/2000
01/15/2000
29-02-2020
29-02-2024
29-02-2000
29-02-2100
29-02-2400
29-0,-11
01/Mar/2020
29/Mar/2020
31 Jul 2020
30 Apr 2020
29 Feb 2020
29 May 2100
8 Aug 2020
26 OCT 2024
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}