import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\(|^\\d )(\\d{3})";
final String string = "415-555-1234\n"
+ "650-555-2345\n"
+ "(416)555-3456\n"
+ "202 555 4567\n"
+ "4035555678\n"
+ "1 416 555 9292";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}