$re = '/(^|\(|^\d )(\d{3})/m';
$str = '415-555-1234
650-555-2345
(416)555-3456
202 555 4567
4035555678
1 416 555 9292';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);