const regex = /(^|\(|^\d )(\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\(|^\\d )(\\d{3})', 'gm')
const str = `415-555-1234
650-555-2345
(416)555-3456
202 555 4567
4035555678
1 416 555 9292`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}