const regex = /(?<=\|\|\burl:|\btitle:|\bdescription:).*?(?=\|\|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\|\\|\\burl:|\\btitle:|\\bdescription:).*?(?=\\|\\|)', 'gm')
const str = `||url:foo||title:Books|Pencils||description:my description||`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}