re = /(?<=\|\|\burl:|\btitle:|\bdescription:).*?(?=\|\|)/m
str = '||url:foo||title:Books|Pencils||description:my description||'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end