$re = '/(?<=\|\|\burl:|\btitle:|\bdescription:).*?(?=\|\|)/m';
$str = '||url:foo||title:Books|Pencils||description:my description||';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);