import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?),\\s+(.*?),(.*?)\\.";
final String string = "The George Washington University, Washington, DC, USA.\n"
+ "Department of Pathology, University of Oklahoma Health Sciences Center, Oklahoma City, USA. adekunle-adesina@ouhsc.edu\n"
+ "Department of Animal Sciences and Division of Nutritional Sciences, University of Illinois, Urbana, IL 61801, USA.\n"
+ "Department of Radiotherapy, Centre of Oncology-Maria Sklodowska-Curie Memorial Institute, Warsaw, Poland. gardas@cmkp.edu.pl\n"
+ "Eastern New York Occupational and Environmental Health Center, Mount Sinai School of Medicine, Department of Community Medicine, Albany, NY, USA. johanni2@crisny.org";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}