re = /^(.*?),\s+(.*?),(.*?)\./m
str = 'The George Washington University, Washington, DC, USA.
Department of Pathology, University of Oklahoma Health Sciences Center, Oklahoma City, USA. adekunle-adesina@ouhsc.edu
Department of Animal Sciences and Division of Nutritional Sciences, University of Illinois, Urbana, IL 61801, USA.
Department of Radiotherapy, Centre of Oncology-Maria Sklodowska-Curie Memorial Institute, Warsaw, Poland. gardas@cmkp.edu.pl
Eastern New York Occupational and Environmental Health Center, Mount Sinai School of Medicine, Department of Community Medicine, Albany, NY, USA. johanni2@crisny.org'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end