const regex = /([0-9]{5})[\/]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{5})[\\\/]', 'gm')
const str = `https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-155/vente-appartement-9-pieces-5-chambres-paris-75007/
https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-192/vente-loft-3-pieces-2-chambres-paris-75010/
https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-184/vente-maison-6-pieces-4-chambres-joinville-le-pont-94340/
https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-166/vente-maison-6-pieces-3-chambres-sevres-92310/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}