re = /([0-9]{5})[\/]/m
str = 'https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-155/vente-appartement-9-pieces-5-chambres-paris-75007/
https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-192/vente-loft-3-pieces-2-chambres-paris-75010/
https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-184/vente-maison-6-pieces-4-chambres-joinville-le-pont-94340/
https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-166/vente-maison-6-pieces-3-chambres-sevres-92310/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end