# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{5})[\/]"
test_str = ("https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-155/vente-appartement-9-pieces-5-chambres-paris-75007/\n\n"
"https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-192/vente-loft-3-pieces-2-chambres-paris-75010/\n\n"
"https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-184/vente-maison-6-pieces-4-chambres-joinville-le-pont-94340/\n\n"
"https://www.nicolasurbain.com/fr/listing-annonces-maison-appartement-loft-paris/ref-nu1-166/vente-maison-6-pieces-3-chambres-sevres-92310/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.