#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(CARBON\b|IRON\b|ZINC\b|\d+(?:\.\d+)?(?:%|\b))|\S"
Local $sString = "CARBON 1569" & @CRLF & _
"1.00% IRON 234" & @CRLF & _
"99% CARBON, 1% IRON 181" & @CRLF & _
"98.2% CARBON 1% ZINC 181" & @CRLF & _
"99% CARBON#1% IRON 141" & @CRLF & _
"ASD CARBON 2% IRON RANDOMWORD 23"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)