const regex = new RegExp('\\b(CARBON\\b|IRON\\b|ZINC\\b|\\d+(?:\\.\\d+)?(?:%|\\b))|\\S', 'gm')
const str = `CARBON 1569
1.00% IRON 234
99% CARBON, 1% IRON 181
98.2% CARBON 1% ZINC 181
99% CARBON#1% IRON 141
ASD CARBON 2% IRON RANDOMWORD 23`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);