import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(CARBON\\b|IRON\\b|ZINC\\b|\\d+(?:\\.\\d+)?(?:%|\\b))|\\S";
final String string = "CARBON 1569\n"
+ "1.00% IRON 234\n"
+ "99% CARBON, 1% IRON 181\n"
+ "98.2% CARBON 1% ZINC 181\n"
+ "99% CARBON#1% IRON 141\n"
+ "ASD CARBON 2% IRON RANDOMWORD 23";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}