import re
regex = re.compile(r"^\d(,|\d)*", flags=re.MULTILINE)
test_str = "123456,54,435,3246,4365243,623,46,432,2,43,5243652,43652436,234,65,2436,32465,234,6523465,234"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")