re = /^\d(,|\d)*/m
str = '123456,54,435,3246,4365243,623,46,432,2,43,5243652,43652436,234,65,2436,32465,234,6523465,234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end