package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{2}[0-9]{8}[A-Z#]{10}$`)
var str = `ABCDEFGHIJKLMNOPQR##
AB12345678KLMNOPQR##
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}