re = /^[A-Z]{2}[0-9]{8}[A-Z#]{10}$/m
str = 'ABCDEFGHIJKLMNOPQR##
AB12345678KLMNOPQR##
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end