$re = '/^[A-Z]{2}[0-9]{8}[A-Z#]{10}$/m';
$str = 'ABCDEFGHIJKLMNOPQR##
AB12345678KLMNOPQR##
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);