const regex = new RegExp('(?<=[a-z])(?=[A-Z0-9])', 'gm')
const str = `DarkFantasy
CalibreIsAwesome!`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);