re = /(?<=[a-z])(?=[A-Z0-9])/m
str = 'DarkFantasy
CalibreIsAwesome!'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result