$re = '/(?<=[a-z])(?=[A-Z0-9])/m';
$str = 'DarkFantasy
CalibreIsAwesome!';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;