using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<houseNumber>[1-9\p{L}][\d\p{L}]*(?:(?: | ?[\-/+,] ?)[\d\p{L}]+)*?),? (?<street>(?!\d+ )[\p{L}\d'\u2018-\u2019]+\.?(?:[ -][\p{L}\d'\u2018-\u2019]+\.?)*(?<! \d+))$";
string input = @"1 Test-Straße
373 Chaussée de Tirlemont
23 Mühlenstraße
135 Straße des 17. Juni
12ab 4th Street
1435 3rd Avenue
11-19 Hamburger Str.
12 K4
12ab Test-Str.
12a-d Test-Str.
51 16 Test Str.
17/18 Test-Str.
QA/3/31 Test Str.
51 / XX / 31 Test Str.";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}