# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<houseNumber>[1-9\p{L}][\d\p{L}]*(?:(?: | ?[\-/+,] ?)[\d\p{L}]+)*?),? (?<street>(?!\d+ )[\p{L}\d'\u2018-\u2019]+\.?(?:[ -][\p{L}\d'\u2018-\u2019]+\.?)*(?<! \d+))$"
test_str = ("1 Test-Straße\n"
"373 Chaussée de Tirlemont\n"
"23 Mühlenstraße\n"
"135 Straße des 17. Juni\n"
"12ab 4th Street\n"
"1435 3rd Avenue\n"
"11-19 Hamburger Str.\n"
"12 K4\n"
"12ab Test-Str.\n"
"12a-d Test-Str.\n"
"51 16 Test Str.\n"
"17/18 Test-Str.\n"
"QA/3/31 Test Str.\n"
"51 / XX / 31 Test Str.")
matches = re.finditer(regex, test_str, re.UNICODE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.