const regex = /^(?<houseNumber>[1-9\p{L}][\d\p{L}]*(?:(?: | ?[\-/+,] ?)[\d\p{L}]+)*?),? (?<street>(?!\d+ )[\p{L}\d'\u2018-\u2019]+\.?(?:[ -][\p{L}\d'\u2018-\u2019]+\.?)*(?<! \d+))$/umg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<houseNumber>[1-9\\p{L}][\\d\\p{L}]*(?:(?: | ?[\\-\/+,] ?)[\\d\\p{L}]+)*?),? (?<street>(?!\\d+ )[\\p{L}\\d\'\\u2018-\\u2019]+\\.?(?:[ -][\\p{L}\\d\'\\u2018-\\u2019]+\\.?)*(?<! \\d+))$', 'umg')
const str = `1 Test-Straße
373 Chaussée de Tirlemont
23 Mühlenstraße
135 Straße des 17. Juni
12ab 4th Street
1435 3rd Avenue
11-19 Hamburger Str.
12 K4
12ab Test-Str.
12a-d Test-Str.
51 16 Test Str.
17/18 Test-Str.
QA/3/31 Test Str.
51 / XX / 31 Test Str.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}