$re = '/(?:^.*\\\\src\\\\)?(\w+)(?!\w*$)|(\W)|(\w+)$/m';
$str = 'c:\\workspace\\src\\chrome\\browser\\ui\\webui\\settings\\about_handler.h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);