# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<qt>['"`])(?<string>.*?(?<!\\)\k<qt>\k<delimiter>)|\k<delimiter>(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<=.*)(?:\\/\\/.*$)|(?<=.*)(?:\\/\*+(?:.|\s)*\*\\/)|(?<delimiter>[;{}\n\/]|^)(?![;{}\n\/])|\s*/$1$2$3$4/gim;t' <<< "function myFunction() {
let carName = \"Volvo\";
'sdf'// here is a comment, string before it should still exist
let banana
const test = 'string with \"quoted substring\"'; let airplane = 'fly';
(\"and another string th'' as' asd 'ere\")
'escaped \' character '
labelForStrings: {
`t'is a\` \"string\"`
}
}
const variableShouldStillExist /*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/
/* single multiline */"