# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<qt>['\"`])(?<string>.*?(?<!\\)\k<qt>\k<delimiter>)|\k<delimiter>(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<=.*)(?:\/\/.*$)|(?<=.*)(?:\/\*+(?:.|\s)*\*\/)|(?<delimiter>[;{}\n/]|^)(?![;{}\n/])|\s*"
test_str = ("function myFunction() {\n"
" let carName = \"Volvo\";\n"
" 'sdf'// here is a comment, string before it should still exist\n"
"let banana\n"
" const test = 'string with \"quoted substring\"'; let airplane = 'fly';\n"
"(\"and another string th'' as' asd 'ere\")\n"
"'escaped \\' character '\n"
"labelForStrings: {\n"
" `t'is a\\` \"string\"`\n"
" }\n"
"}\n\n\n\n\n"
"const variableShouldStillExist /*asd *****\n"
"* 324 @*l;;?\\\\\\\n"
"* multiline comment \n\n\n"
"*** /\n"
"*/\n"
"/* single multiline */")
subst = "$1$2$3$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.