const regex = /(?<qt>['"`])(?<string>.*?(?<!\\)\k<qt>\k<delimiter>)|\k<delimiter>(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<=.*)(?:\/\/.*$)|(?<=.*)(?:\/\*+(?:.|\s)*\*\/)|(?<delimiter>[;{}\n/]|^)(?![;{}\n/])|\s*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<qt>[\'"`])(?<string>.*?(?<!\\\\)\\k<qt>\\k<delimiter>)|\\k<delimiter>(?:[ \\t\\v])*(?<keyword>(?:const|let|function)\\s)|(?<=.*)(?:\\\/\\\/.*$)|(?<=.*)(?:\\\/\\*+(?:.|\\s)*\\*\\\/)|(?<delimiter>[;{}\\n\/]|^)(?![;{}\\n\/])|\\s*', 'gim')
const str = `function myFunction() {
let carName = "Volvo";
'sdf'// here is a comment, string before it should still exist
let banana
const test = 'string with "quoted substring"'; let airplane = 'fly';
("and another string th'' as' asd 'ere")
'escaped \\' character '
labelForStrings: {
\`t'is a\\\` "string"\`
}
}
const variableShouldStillExist /*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/
/* single multiline */`;
const subst = `$1$2$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);