import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=aba|a$)(?:a(b+)(?=a\\1ba|a$))*a$";
final String string = "a\n"
+ "aba\n"
+ "ababba\n"
+ "ababbabbba\n"
+ "ababbabbbabbbba\n"
+ "ababbabbbabbbbabbbbba\n\n"
+ "abba\n"
+ "abbba\n"
+ "aa\n"
+ "abbaa\n"
+ "aabb\n"
+ "abababa\n"
+ "ababbba\n"
+ "abbaba\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}