#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[a-zA-Z_]+:[a-zA-Z_]+:[a-zA-Z_]+(?:;(?!$)|$))+$"
Local $sString = "a_b:bread:stack_overflow;test:this_thing:jane;Get_me:h:down" & @CRLF & _
" ab:bread:stack_overflow;test:this_thing:jane;Get_me:h:down" & @CRLF & _
"a_b:any other characters break it:stack_overflow;test:this_thing:jane;Get_me:h:down" & @CRLF & _
"a_b:bread:format_messed_up-test:this_thing:jane;Get_me:h:down" & @CRLF & _
"a_b:bread:stack_overflow;test:this_thing:jane;semi_colon_at_end;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")