# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[a-zA-Z_]+:[a-zA-Z_]+:[a-zA-Z_]+(?:;(?!$)|$))+$"
test_str = ("a_b:bread:stack_overflow;test:this_thing:jane;Get_me:h:down\n"
" ab:bread:stack_overflow;test:this_thing:jane;Get_me:h:down\n"
"a_b:any other characters break it:stack_overflow;test:this_thing:jane;Get_me:h:down\n"
"a_b:bread:format_messed_up-test:this_thing:jane;Get_me:h:down\n"
"a_b:bread:stack_overflow;test:this_thing:jane;semi_colon_at_end;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.